jQuery1.8になって動かなくなったコード

rails使っていてjQueryのバージョンを固定していないでbundle updateをするとjQueryのバージョンが新しくなります。
jQueryのバージョンが新しくなったことによって動かなくなったりすることがあるので、注意が必要ですね。

jQueryの最新が1.9.1なのでjQuery1.9になって使えなくなったAPIにも注意したいですね。こちらも後ほどまとめてみたいと思います。

1.7.1で動いていたのに1.8にしたら動かなくなったコード

$('#slider_wrap').animate({marginLeft: '-100px'},{duration:0});

回避策

$('#slider_wrap').css('margin-left', '-100px');
Ruby on RailsによるWEBシステム開発、Android/iPhoneアプリ開発、電子書籍配信のことならお任せください この記事を書いた人と働こう! Ruby on Rails の開発なら実績豊富なBPS

週刊Railsウォッチ

インフラ

BigBinary記事より

ActiveSupport探訪シリーズ